Update to Sellics Seller Edition Platform
Resolved
This incident has been resolved.
Posted Nov 30, 2020 - 14:30 CET
Monitoring
Dear Sellics User,
We would like to inform you that we are currently making a few small updates to the Sellics Seller Edition Platform which might lead to limited access to the tool for some users. We are working as quickly as possible and should have this completed soon.

We are apologise for any inconveniences caused by this.

Best regards,
Your Sellics Team
Posted Nov 26, 2020 - 00:38 CET
This incident affected: Seller Edition (Cockpit, Sales & Profit).