Advertising systems are experiencing delays
Resolved
Amazon reports that the incident has been resolved and the data has been updated for all accounts.
Posted Nov 27, 2020 - 11:48 CET
Identified
Amazon reports delays and missing data in reporting across most Amazon Advertising products since November 24th.
We will keep you informed as soon as Amazon has fixed this issue.
Posted Nov 26, 2020 - 11:16 CET
This incident affected: Seller Edition (PPC Manager).